Related Procedures Related Topics: Add a Child Code Use the Code Details dialog box to add a child code to a code file. Add Codes to a Code File Use the Code Details dialog box to a code to a code file. Assign a Code File Using Project Properties You can use the Project Properties dialog box to assign a code file to a project. Assign a Code File Using the Open Plan Explorer You can use the drag-and-drop feature in the Open Plan Explorer to assign a code file to a project or resource file. Assigning a View to a Code File There are several ways to assign a code view to a code file. Assign Code Files to the Project Directory or the Activity/Resource Tables You can assign code files to the Project Directory or to the Activity or Resource tables when creating a new project. Attach a Note to a Code Use the Notes tab of the Code Details dialog box to attach a note to a code. Change the Code File Prompt for an Assigned Code File Use the Code File Prompt dialog box to change the code file prompt for an assigned code file. Change the Font in a Code View Use the Font dialog box to change the font in the Code View. Collapse a Parent Code Use this procedure to collapse a parent code or all parent codes. Copy a Code File Use the Save As dialog box to copy a code file. Create a Code File Use this procedure to create a code file. Create Codes in a Code File Use the Code Information dialog box to create codes in the code window. Define Code Display Options Use the Options tab of the Code Display Preferences dialog box to define code display options. Delete a Code If you delete a parent code, Open Plan warns you that all child codes will be deleted along with the parent. If you delete a code that has been assigned to an activity in a project, that assignment is deleted as well. Delete a Code File You can only delete a code file from the database if the file is not open, if it is not being used by another project or resource file, and if you have the appropriate rights to the file. Delete a Code Note Use the Code Details dialog box to delete a code note. Display Code Descriptions Use the Box Layout tab of the Code Display Preferences dialog box to display code descriptions in the code boxes. Display Full Code IDs Use the Options tab of the Code Display Preferences dialog box to display full code IDs in the code boxes. Edit a Code Use the Code Details dialog box to edit a code. Edit a Code Note Use the Code Details dialog box to edit a code note. Expand a Parent Code Use this procedure to expand a parent code. Expand All Parent Codes Use this procedure to expand all parent codes. Find a Code Use the Find Node dialog box to find a code. Moving a Code in the Hierarchy When you move a code (or group of codes) to a different position in the code hierarchy, Open Plan automatically renumbers the code IDs of the moved codes. Open a Code File Using the File Open Dialog Box Use the File Open dialog box to open a code file. Remove a Code File from a Project Deleting a code file from a project folder removes any activity code assignments based on that code file. Remove a Code from a Resource File Use the Assign Code dialog box to remove a code file from the resource file. Save a Code File There are several ways to save a code file. Set Code Box Layout Options Use this procedure to set the code box layout options. Assign a Code File Using Resource File Properties Use this procedure to assign a code file to a resource file using the Properties dialog box. Parent Topic: Working with Codes